Project

The Project Menu offers the following areas:

  • an Overview of the selected project
  • Version Information containing information about releases and publications of the project information)
  • History of artefacts of the project
  • a list of Identifiers used in the project
  • Forms with ADA (not yet implemented)
  • a Development area to check your project for consistency, e.g. before publications, or to create validation scripts and methods.

If you are logged in and an author of the project, the following additional areas are offered:

  • a list of Authors contributing to and associated with the project.
  • a panel to see and maintain DECOR locks on artefacts
  • entry to the MyCommunity area offering community specific information
  • the section about Governance Groups the project belongs to.

Overview

image-20220726192149227

In this Panel 1 you get an overview about the project, its Statistics 2, Properties and Settings 3. There are also cards for Copyright Information 4, Scheduled Project Tasks 5 and defined Services 6. The overview is completed by the list of referenced Repositories 7 and Namespaces used 8.

Depending on whether you are a logged-in project author or not, additional options appear.

Statistics Cards

Below Project information, description and icon you see the Statistics Cards 2 that are also clickable for direct access to Datasetsopen in new window, Scenariosopen in new window, Terminologyopen in new window, Templatesopen in new window, Issuesopen in new window and Publicationsopen in new window.

Properties Card

In the Properties Card 3, Identifiers, Languages, Switches and Publication Locations are shown. Clicking on a tab opens it, clicking again on an open tab collapses the Property Card tabs.

Identifiers gives you an overview of the project prefix, id and last modified date.

image-20220726175452839

In the Project Languages tab you can edit the name of the current project in one or more different languages or add new languages to the project. You also can see and switch which language is the so-called default language. There are comprehensive explanations in this area.

image-20220726175645618

The Switches tab allows to make the project private or public, to declare that the project contains reusable content, to declare the project as experimental/test or not and to switch the notifier on or off. There are comprehensive explanations in this area.

image-20220726175803319

The Publication Location tab gives you the option to edit the location of the publication or to delete the location. It also allow you to overview the publications-related external processes, the Release and Archive Manager (ADRAM) and the Automated Wiki Bot (ADAWIB), if configured and parametrized for this project.

image-20220726180034964

Copyright 4 provides an overview of the Copyright Information for the current project. It is also possible to add a new Copyright or to maintain the existing ones.

image-20220726180538211

Scheduled Project Tasks Card

Scheduled Project Task 5 provides a list of actual running tasks for the project and their status, e.g. a publication request. If a task has not been completed it is also possible to delete the task.

image-20220726180844615

Services Card

Services 6 contains a list of services defined for the project along with the specified format. You can add new or maintain existing ones.

image-20220726180923027

Repositories Card

Repositories 7 gives you an overview of the repository reference used for the project with repository prefix, url and type. To add a new repository reference to the project simply use the ADD button. The ADD dialog offers also a search for a specific repository.

It is not possible to un-reference (delete) a repository reference.

image-20220726181451690

Namespaces Card

Namespaces provides an overview of which namespaces are used in the current project. To declare a current namespace as default you can select it in the default column.

image-20220726181803612

You can also add a new namespace by clicking the ADD-button.

WARNING

Please be cautious and sure that you know what you are doing when maintaining namespaces. Unthoughtful actions on namespaces may even make the project unavailable to you or may cause errors on validation.

Authors

The Authors panel is only available if you are logged-in project author. It provides an overview of all authors of the project, their name and whether their account is active or not. More details like email address, subscriptions and expiration date can be seen when expanding the row. It is also possible to add an new author the current project via the + button.

image-20220726182752533

Publications

The Publications panel provides the list of existing publications and gives you the option to add a new publication to the current project.

image-20220726183148847

The status of a publication or publication request is shown in the status column.

image-20220726183906233

An Intermediate Version acts as a kind of backup of the current state of the project. For this purpose the project is historicized as a whole, this is shown with a green hollow diskette symbol 1.

For Releases, option 1 is to only save the project, as a "freeze". This saved-only release is not published elsewhere but can act as a starting point for further releases of the project and the corresponding release notes. The saved-only release are denoted with a green diskette symbol 2.

If a Release is properly processed and published at its Publication Location, the Status if the release is indicated (in the example "active"), and the green diskette symbol says it is stored, the bookshelf symbol says it is published at its Publication Location 3. The Status of the Publication can be changed according to the Release status workflow.

Once processed in the first phase (compilation of all project artefatcs needed), the corresponding icon is a clock that the external continuatioin process (ADRAM) 4.

Triggering a Release

Click on the + button in the Publications Panel to initiate a new Release Publication.

A new window with three tabs will open where you can set the options for the Publication. Choose a previous Release (if any) on which to base the Release Notes for this publication.

image-20220726185653423

Add or refine the Release Notes 1.

Choose whether you want to initiate an Intermediate Version (historicized project) or a Release 2. If a Release shall be created, assign a Release Label 3.

You can decide to have a development / test release only 4 instead of a proper publication.

Choose the languages of the Publication 5.

Finally set the Publication Request to on 6 if the Release shall be published at the pre-defined Publication Location.

image-20220726191059656

NOTE

If you want a Release to be officially published at its pre-defined Publication Location, you must switch the corresponding switch 6 to "on".

In the Parameters tab you can switch specific parameters on or off. Information buttons provide more information about the parameter.

image-20220726190356811

You can also add filters to the Publication based on one or more Scenarios via the Filter tab. Add a filter using the + button. A list of all possible Transactions in the project is shown. Choose one or more Transactions that shall act as a filter. It is required to give a label to the filter.

image-20220726190754942

A defined filter is then offered to be used for the Publication ("Select filter") in the Filter tab. Click to select the filter for the publication.

image-20220726190841693

TIP

In fact a filtered publication is a Scenario/Transaction or use case based publication including only those artefacts actually belonging to the Scenario/Transaction. This is especially useful for larger project that cover multiple use cases.

Process of Release Publication Requests

If a Release is triggered it is shown initally as a waiting-in-queue.

image-20220726185054288

During the process the progress is shown.

image-20220726185132945

Once processed in the first phase (compilation of all project artefatcs needed), the corresponding icon is a clock. The hover text tells that in this state it is waiting for the external continuatioin process (ADRAM).

image-20220726184844401

Once it is taken over by ADRAM, the progress of the second phase (the actual transformation of the release and its publication) is denoted by a gondola, along with progress information.

image-20220726185401392

If a release publication process fails it is displayed as an error.

image-20220726185224853

NOTE

A number of checks can be done to improve the quality of your project before you create and publish a release. To check the quality of terminology content contained in the project you can perform a Terminology Report.

History

The History panel provides you an overview of all edit activities of current project. It is also possible to search for a specific activity. You must be a logged-in project author to see this panel.

image-20220726191708519

Identifiers

The Identifiers panel provides an overview of all Identifiers used in the current project. The are divided into two sections:

  • Base Ids
  • Other Ids.

Base Ids

Base Ids, shown in the lower part of the Identfiier Panel, represent the set of root identifiers (OIDs) for ART-DECOR artefacts used by the project as default assignments for new Ids and for display purposes.

image-20220726212740650

A Base Id has an OID (root), type of artefact and a so-called prefix that is used for short names for ids. It is possible to add and maintain the ids, or make a certain Base Id the default.

image-20220726225600120

EXAMPLE

If you create a new Code Systems where you don't have an own identification for, ART-DECOR assigns an id based on the Base Ids for Code Systems (see above). According to the recommendations of the ISO standard ISO/TS 13582:2015(en) Health informatics — Sharing of OID registry information, the new Code System for example gets the first free id based on the root ending on .5 concatenated with the first free last digit of the already exsiting Code Systems in the project.

Other Ids

Other Ids are external Ids such as terminology Ids (OIDs or URIs) for LOINC and SNOMED etc. or for identification schemes such as the Dutch National Citizen Identfier (BSN). It is possible to add and maintain an id, add a designation or associate a URI.

image-20220726212400441

Base Ids

DECOR locks

In the DECOR locks panel you have an overview of all locks of the current project. You can see which type the lock is, the name, prefix and how many days it has is locked. It is also possible to delete a lock, either one-by-one or for a whole holder of locks.

2022-06-27_11-22-22.png

MyCommunity

In this panel you have directly acces to the MyCommunity board.

image-20220728140338126

Governance Groups

This panel allows you to create and maintain Governance Groups.

image-20220728140506576

Development

The Development Panel offers various features for authors of a project during developers of a specification. The feature include

  • to check the underlying internal specification file, called DECOR Project file.
  • to compile a development version based on the current status of the Project
  • to manage ART-DECOR artefatcs of the Project.

The features are arranged with tabs, initially the CHECK DECOR tab is selected.

image-20220728143116746

Check DECOR

The CHECK DECOR tab gives you the option to validate the project, in essence the underlying internal specification file (DECOR file). If there has been a previous check you can see when the results.

image-20220728144744756

Define Project Checks

To validate the project you click on the CHECK DECOR button and a new window will open where you can configure optional checks and other settings. When you click on the Information icons you can see what each configuration means in detail. Once you've selected the configuration option you need, you can then click on the NEXT button.

image-20220728143633945

In the next step you can select or specify filters on which transaction(s) you wish to perform the check. To add a filter click on the + button and a new window will open where you have the option to filter a specific transaction to validate. If you don't need to filter out you can directly click on the NEXT button.

Adding a label to the selected transaction is required, this is the name of the filter the selection.

image-20220728143915217

You can then click on save and the filter will be added to the DECOR CHECK where they can be selected/de-selected for the actual check.

image-20220728144010415

By clicking on the NEXT button you come to the last part of the DECOR CHECK dialog where you see an summary of the configuration, filter and compiled settings.

image-20220728144115985

You can then click on CHECK DECOR. As soon as you start the CHECK DECOR and it's ready the current window will automatically refresh.

Results of a Check

The results of the DECOR check is done through schema and schematron validation and are listed below where you have an overview of the different part of the validation.

image-20220728144533675

It is also possible to filter out the results of the check / validation using the filter icon.

image-20220728144556109

Compile a development version

You can Compile a Development Version of your project which essentially compiles your project in current state with a number of options

  • create schematrons (open or close)
  • create explicit includes (an Information button tells more about this option)
  • select one or more Transactions from your project to set the focus on the selected ones.
image-20220728145143486

The overall result is shown after processing in the list. Historic compiles are store also but marked automatically as deprecated if they are the thirs or higher generation of compilations.

image-20220728145721364

You can also delete or download an existing schematron package or do a live validation of an XML instance against the compiled schematron packages.

image-20220728145807039

Live Validation of Instances

You can validate XML instances against your development packages directly in the tool. Choose first a compiled environment from the list.

A dialog opens and offers you to Upload the instance to be validated and to select a Transaction from the list. Then you click on VALIDATE.

image-20220728150339332

The results of the validation (schema and schematron from the development environment) are shown in the Report tab.

image-20220728150602344

Artefact management

In the tab Artefact management you can

  • trigger a Terminology Report
  • add element and attribute ids to your project.

image-20220728150846582

It is possible to initiate a Terminology Report to check the terminologies used in your project. The report detects whether a coded concept in a value set has an illegal display name or is deprecated and should no longer be used. Usually a Terminology Report check will be perfomed before creating a publication, as part of preflighting publication and quality checks but could of course be run more often. For projects with large or many value sets this can be a lengthy process.

It is also possible to add internal id's to all Template elements and attributes in the project. This is rarely done manually as ART_DECOR tries to assign internal id's to all Template elements and attributes when maintaining Templates.

Project Index

The Project Index allows you to inspect summaries of all ART-DECOR artefatcs of your Project. Use the artefact tabs to flip between the different kinds of artefatcs. Each tab also offers a variety of download options in different formats through the colored pills.

image-20220728151301581

As usual green pills are used for Care provider oriented artefacts, blue pills for Terminologist and red pills for Data Format Specialists and Technicans.

image-20220728151400568

Last Update:
Contributors: dr Kai U. Heitmann, Vanessa Braumüller